RAV4 II 2.0 D-4D - Klimaanlage Fehlercode 21 - aber Sonnensensor ist OK

Diskutiere RAV4 II 2.0 D-4D - Klimaanlage Fehlercode 21 - aber Sonnensensor ist OK im Elektrik Forum im Bereich Technik; Hallo Toyota - Freunde, Ich habe einen RAV4 CLA21 (2,0 D4-D) Bj. 2004. mit Klimaautomatik. An heißen Tagen wie heute schaltet sich die...

  1. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Hallo Toyota - Freunde,

    Ich habe einen RAV4 CLA21 (2,0 D4-D) Bj. 2004. mit Klimaautomatik. An heißen Tagen wie heute schaltet sich die Klimaanlage nach ca. 10 Minuten Laufzeit aus und der AC-Knopf blinkt. Wenn man das Auto ca. 15 - 20 Minuten abstellt läuft die Klimaanlage wieder normal an, kühlt gut, schaltet sich jedoch nach ca. 5 Minuten wieder ab.

    In der Werkstatt wurde bereits folgendes gemacht:

    Anlage mit neuem Kühlmittel gefüllt + Dichtheitsprobe etc. - es fehlte kein Kühlmittel, die Anlage ist dicht, auch der Druck passt. Auch der Temperatursensor der Anlage ist ok laut Werkstatt.

    Also wurde der Fehlercode der Klimaanlage (gleichzeitiges Drücken von "Auto" + "Umluft") ausgelesen - der Fehlercode 21 (Sonnenlichtsensor) wurde angezeigt.

    Ein neuer originaler Toyota-Sonnenlichtsensor wurde eingebaut - selbes Problem wieder. Da es ja sein kann dass auch der neue Original-Sensor von Toyota kaputt geliefert wird, wurde ein Sensor einer funktionierenden Anlage von einem baugleichen Fahrzeug eingebaut - wieder das selbe Problem.

    Von einem anderen gebrauchten RAV4 wurde daraufhin die Klimaautomatik-Bedienkonsole eingebaut - wieder das selbe Problem. Die Verkabelung des Sonnenlichtsensors wurde durchgemessen - da passt angeblich auch alles. Auch der Motortester von Toyota, der das Hauptsteuergerät über OBDII durchcheckt hat keine Fehler entdeckt.

    Seltsam ist, dass das Problem nur bei hohen Temperaturen auftritt (ab ca. 28° - 30° Außentemperatur) bei 25 - 26-Grad und Stop & Go-Verkehr in der Stadt macht die Klimaanlage was sie soll. Die Magnetkupplung schaltet dann sauber und alles geht gut - die Anlage kühlt dann auch gut. Aber gerade wenns so richtig heiß ist versagt sie den Dienst.

    Ich weiß nicht mehr weiter - auch die Werkstatt hat vorerst mal aufgegeben. Hätte jemand von euch eine Idee wo ich noch suchen könnte?



    Viele Grüße



    Gerhard
     
  2. Anzeige

  3. #2 Schuttgriwler, 21.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
    Also den Sonnenlichtsensor zu wechseln war so unnötig wie dem Papst seine Eier, denn die Klimaautomatik zeigt immer Fehler 21 an, wenn man den Testmodus aufruft, UND der Wagen im Schatten / Halbdunkel / nicht in der prallen Sonne steht. Der Sensor korrigiert lediglich die Steilheit der programmierten Kurve Außentemperatur <> Solltemperatur in Abhängigkeit zum aufheizenden Sonnenlicht als Störfaktor, welches auf den Wagen fällt, also die Gebläseleistung. Mehr Sonne = mehr Gebläse.

    Wie sieht es im Schauglas der Hochdruckleitung aus ? Perlt das Kältemittel ? Schäumt und sprudelt es ? Strömt fast unsichtbar geschlossen ?

    Funktionieren die Ventilatoren vorne am Kondensator, in beiden Geschwindigkeiten ? Wird AC eingeschaltet drehen beide mit halber Drehzahl (beide über Relais in Reihe an 12V), stellt man die Klima auf Temp MIN und Vent MAX und gibt Gas, müssen beide umschalten auf schnelle Drehzahl (Relaisblock vorne im Motorraum schaltet um auf beide an 12V parallel).

    Führen zum Kompressor 1 / 2 oder 3 / 4 Kabeladern hin ? Die D4D hatten damals keine Kompressorblockadeüberwachung, zumindest in meinen Handbüchern zum 2001er CVerso nicht.
     

    Anhänge:

  4. #3 Schuttgriwler, 21.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32


    Hier mal das Schauglas meines Lexus, der CVerso steht im Tabakschuppen abgemeldet, war zu faul zum hinlaufen.
     
  5. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Hallo, vielen Dank für die Infos.

    Das von dir beschriebene Schauglas gibt's bei meinem RAV4 leider nicht. Die Ventilatoren tun meiner Meinung nach das was sie sollen. Bei kaltem Motor im Stand stehen sie still - bei AC-Aktivierung laufen beide langsam, steigt man auf´s Gas erhöht sich die Drehzahl der Ventilatoren, geht man vom Gas runter sinkt die Drehzahl nach ein paar Sekunden wieder. Die beiden Relais (Fan 1 und Fan 3 - siehe Bilder) hab ich auch durchgecheckt - die schalten einwandfrei. FAN1 ist der große rechte Ventilator und der 2er der kleine linke. Wenn ich beide überbrücke laufen sie auf Dauerplus auch im Stand auf der langsamen Stufe. Wo der Saft für die schnelle Stufe herkommt weiß ich nicht. Beide Relais haben nur 4 Kontakte.

    Den gespeicherten "Sonnenlicht-Sensor"-Fehler hab ich durch ziehen der Klimaanlagensicherungen und 20sekündigem Warten gelöscht - der taucht nun auch nicht mehr auf.

    Nun hab ich auch den Zwischenraum zwischen Wasserkühler und Klimakondensator kontrolliert um sicher zu sein dass da kein isolierender Mist drinnen liegt - war alles sauber. Durch den Kühlergrill hab ich noch versucht so viel wie möglich an Staub mit dem Dampfstrahler aus dem Kondensator zu blasen. Aber eigentlich müsste eine zu hohe Temperatur am Kondensator ja vom Fehlerspeicher registriert werden oder? Da war aber bis dato nichts. Auch die Kühlmittelleitungen erscheinen mir nicht allzu heiß zu sein.

    Leider ist es heute bewölkt und es wird vermutlich noch regnen - da kann ich eine Auswirkung meiner "Sonderreinigung" nicht so richtig testen, da es zum beschriebenen Fehler und Aussetzen der Klimaanlage nur dann kommt wenn man sie wirklich braucht - ab ca. 30°.

    Angeblich soll mein RAV4 diese Kompressorblockade-Überwachung bereits in der Magnetkupplung eingebaut haben. Ich denke mir, wenn es am Kompressor liegen würde, dann würde der ja auch bei niedrigeren Temperaturen den Geist aufgeben oder man würde es ev. hören (Keilriemen quietscht kurz auf etc.). Das kann es eigentlich nicht sein - er schaltet ein/aus wie es sein soll.

    Auf jeden Fall hat es etwas mit der Außentemperatur zu tun. Ich warte nun bis der Fehler erneut auftritt (wahrscheinlich nur dann wenn ich schon am vertrocknen bin).

    Viele Grüße,

    Gerhard
     

    Anhänge:

  6. #5 Schuttgriwler, 22.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
    Hallo,

    Km Stand ?

    das Schauglas hat er sicherlich, such mal, denn es ist nicht einheitlich am gleichen Ort. Bitte prüfe das nach und beobachte ob Bläschenbildung vorhanden.

    Die Leitung zum Verdampfer im Innenraum hin, muß sehr warm bis heiß werden, bei intensiver Last (heiße Außenluft & große Gebläseleistung). Wird sie das nicht, fehlt Kältemittel oder ist zuviel drin.

    Die Reinigung der Kühler ist sicherlich nicht falsch, aufpassen bei Nutzung eines KÄRCHER, daß die Lamellen nicht verbogen werden. Habe ich bei unseren Linienbussen sehr oft machen müssen, die haben allen Straßendreck angesaugt.

    Nein, die Kältemitteltemperatur wird nicht registriert.

    Ich hatte bei meinem LS400 auch das Problem, daß bei kühler Witterung / kühlem Motorraum die Klima ging und dann irgendwann AC blinkte. Letztendlich nach mehreren Versuchen stellte sich heraus, daß die Magnetkupplung rutschte in heißem Zustand. Muß man mit Taschenlampe leuchten und genau hinsschauen, ob vorne die Stirnnabe sich mitdreht, oder anfängt rutschen.
     
  7. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Hallo, das Auto hat 177.000 km drauf. Deiner Beschreibung nach könnte es auch bei mir die Magnetkupplung sein. Hab mir die Preise für die Kompressoren mal angeschaut, wenn ich dazu kalkuliere dass die Anlage wieder gefüllt werden muss + Arbeitszeit, zahlt sich das bei dem alten Auto nicht mehr aus.

    Das Reinigen des Kühlers / Kondensators hat nix gebracht, hatte gestern, obwohl "nur" 27° Außentemperatur wieder das selbe Problem.

    Fehlermeldung kam keine im Steuergerät. Hab im Netz noch günstig eine gebrauchte Steuereinheit bestellt, das probiere ich noch, dann lass ichs sein, dann wird's wohl die Magnetkupplung sein...

    *schwitz*
     
  8. #7 Schuttgriwler, 23.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
    Schau mal bei Rockauto.com ob du dort den passenden Kompressor oder im Zubehör die Magnet Kupplung bekommst.

    Schick mal deine Fahrzeug VIN ich schaue in den diversen Katalogen nach.

    Nichts ist unmöglich......
     
  9. #8 Schuttgriwler, 23.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
    https://www.kfzteile24.de/artikelsu...42060&search=88410-42060&searchType=universal

    ACHTUNG ! Unterschied !

    https://www.kfzteile24.de/artikelsu...44060&search=88410-44060&searchType=universal

    In Juli 2003 wurden Änderungen vorgenommen !

    Dein Wagen hat einen DENSO 10S15L drin, nur mit unterschiedlichen Abgängen je nach Produktion, die kann man ggf ummontieren, also ich sehe da kein Problem darin, das Problem zu lösen.

    https://www.google.com/search?q=Den.....69i57j0l2.6118j0j7&sourceid=chrome&ie=UTF-8
     
  10. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Meine VIN ist: JTE HG20 V706 0613 92
     
  11. #10 Schuttgriwler, 23.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
  12. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Vielen Dank für die Infos!

    Viele Grüße Gerhard
     
    Schuttgriwler gefällt das.
  13. #12 Schuttgriwler, 25.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
     
  14. Anzeige

    Schau mal hier: (hier klicken). Dort findet man Infos und Antworten.

    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  15. gerryt

    gerryt Grünschnabel

    Dabei seit:
    09.04.2011
    Beiträge:
    14
    Zustimmungen:
    1
    Fahrzeug:
    Toyota RAV4 (2004) 2.0 D-4D
    Habe das Schauglas beim RAV4 nun entdeckt - leider ist es verschmutzt und ich muss für die Reinigung ein paar Sachen abbauen, sonst komm ich nicht dazu. Ich nehme an, dass in deinem Video zu sehen ist wie es bei ordnungsgemäßer Funktion aussieht wenn das Kühlmittel vorbeiströmt wenn der Kompressor läuft bzw. dass es im Schauglas ruhig ist wenn die Magnetkupplung abschaltet.
     
  16. #14 Schuttgriwler, 27.07.2020
    Schuttgriwler

    Schuttgriwler Lebende Foren Legende

    Dabei seit:
    18.04.2001
    Beiträge:
    9.809
    Zustimmungen:
    199
    Fahrzeug:
    KP60, KP61, CDE120J1, E10, E11, UCF20, RH32
    Hallo kannst den Finger nehmen um das Schauglas sauber zu reiben. Das Kältemittel muss bei maximaler Last ruhig Strömen
     
Thema:

RAV4 II 2.0 D-4D - Klimaanlage Fehlercode 21 - aber Sonnensensor ist OK

Die Seite wird geladen...

RAV4 II 2.0 D-4D - Klimaanlage Fehlercode 21 - aber Sonnensensor ist OK - Ähnliche Themen

  1. Schloss Fahrerseite SXA10 Rav4 I

    Schloss Fahrerseite SXA10 Rav4 I: Hallo Alle, ich weiß nicht, ob ich in dieser Kategorie richtig bin, sorry falls nicht. Disclaimer: Sorry falls die Fragen total blöd sind, habe...
  2. RAV4 HSD, Probleme mit der Hilfsbatterie

    RAV4 HSD, Probleme mit der Hilfsbatterie: Hat jemand Erfahrung gemacht mit schwächelnder Hilfsbatterie?
  3. Schaltplan RAV4 (ALA4x) gesucht (2012 - 2018)

    Schaltplan RAV4 (ALA4x) gesucht (2012 - 2018): Hallo, vom Vorgänger RAV4.3 (3. Generation) hab ich den Schaltplan und einige sinnvolle Funktionserweiterungen einbauen können / für meinem...
  4. 20/21/22 Zoll Felgen auf RAV4 2020

    20/21/22 Zoll Felgen auf RAV4 2020: Hallo Ich möchte gerne grössere Felgen auf meinem RAV4 Black Edition. Habe aktuell 19" drauf. Hat jemand Bilder? Danke
  5. Gasanlage Rav4 I (SXA10)

    Gasanlage Rav4 I (SXA10): Hallo alle! Ich wüsste gerne, ob jemand weiß, ob es möglich ist den Rav4 SXA10 (also erste Generation) auf eine Gasanlage umzurüsten? Ein...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden